Resolved
This incident is now resolved and our upstream services and integrations are running as normal. Thank you for your patience while we worked through this.
Monitoring
The upstream issues affecting our email delivery have been resolved and this service has returned to normal. Thank you for your patience while we worked through this. We are still monitoring the situation in case of delays with actions linked to external integrations which may also have been disrupted.
Identified
We've improved our email delivery service, but are continuing to see problems with an upstream provider that may affect other integrations and services connected to Linear.
While this is ongoing, users may expect delays or errors with Linear's email integration and connections to other applications like Slack and Intercom due to delayed requests between these services.
Identified
We’ve made a change to our email delivery service temporarily to avoid these errors and improve email delivery speeds.
We’re continuing to investigate the potential impact to other connected services and will share more updates as soon as possible.
Investigating
We're currently affected by an outage from an upstream provider which is disrupting delivery of emails from our mail service. We will keep our status site updated with more information as we monitor.