Resolved
Performance has returned to normal, and updates in Linear are now processing as expected.
Monitoring
We identified elevated latency causing delays for updates in Linear. Some changes may take longer than expected to appear while services stabilize.
We’re continuing to monitor recovery and will share another update once the issue is fully resolved.