Resolved
The increased latency has been resolved, and Linear should be operating normally again.
We rolled back the query change that caused the slowdown and have confirmed performance has recovered.
Monitoring
We’ve rolled back a recent change that may have contributed to the slowdown and performance is improving.
We’re keeping a close eye on continued recovery.
Investigating
We're investigating reports of general latency when taking actions in Linear — we're working to confirm the suspected root cause and remediate the degradation.
We'll provide updates as we have them.