Resolved
Recent feature roll-outs added extra load to our databases, and a fix has been implemented. Thank you for your patience while we worked to resolve this.
Monitoring
We are seeing improvements after updates and are continuing to monitor for stability.
Investigating
Some customers in the US region are still experiencing issues with Linear loading. We have rolled back a recent change and are continuing to mitigate the issue, but some affected users may still see problems. We’ll share another update shortly.
Investigating
Some customers are experiencing issues with Linear loading. We are investigating - apologies for the inconvenience.