Resolved
Normal functionality has resumed.
Monitoring
We're aware of upstream issues which may cause increased delays or failed delivery of Android push notifications primarily in the US region. We will continue to monitor the upstream providers status and keep our status site updated accordingly.