Resolved
Application slowness

Started
June 01, 2021 at 2:56 PM
Status
Resolved after 12 minutes
Affected
Application
Web app
Integrations
API
Application
Desktop app
Application
Sync

Impact

Operational
  • Resolved
    June 01, 2021 at 3:08 PM

    Our database experienced slowness. Application performance is now back to normal and we'll keep monitoring the situation.

  • Investigating
    June 01, 2021 at 2:56 PM

    We are currently investigating incident which is causing slowness in the application.