Resolved
Figma links are slow to render previews

Started
March 14, 2022 at 2:18 PM
Status
Resolved after about 4 hours

Impact

Operational
Affected
Integrations
API
  • Resolved
    March 14, 2022 at 5:52 PM

    Performance issues have been resolved related to Figma's API and Figma embedding is working normally.

  • Investigating
    March 14, 2022 at 2:18 PM

    We are currently investigating why Figma embeds may take several minutes to preview the Figma file within Linear.

    You can add Figma links without the preview in the meantime using CTRL+L to add URLs, as a hyperlinked text or by temporarily disabling the integration. (Previous Figma previews will not be affected)