Resolved
Investigating slow performance with Linear

Started
September 27, 2022 at 8:34 AM
Status
Resolved after about 16 hours

Impact

Operational
Affected
Application
Desktop app
Sync
Web app
Integrations
API
  • Resolved
    September 28, 2022 at 12:52 AM

    We've resolved the issue. A breaking change in one of the models caused all clients to refresh the local database which overloaded our main database. We're taking steps to prevent this from happening in the future.

  • Monitoring
    September 27, 2022 at 5:33 PM

    We implemented a fix and we're currently monitoring the result. Thanks so much for your patience while we worked on this.

  • Investigating
    September 27, 2022 at 4:42 PM

    We are continuing to investigate and will update as soon as we have further news to share. Thanks for your patience while we work on this.

  • Investigating
    September 27, 2022 at 3:31 PM

    We are investigating further reports of slow performance with Linear. We'll update shortly with further news.

  • Resolved
    September 27, 2022 at 9:35 AM

    Issues with slowness in the app and API should now be resolved. Apologies for any disruption caused.

  • Investigating
    September 27, 2022 at 8:34 AM

    We are currently investigating and working to mitigate this issue.