Some issues not appearing in search
Resolved
Degraded performance
Lasted for 2d

This incident has been resolved.

Wed, Apr 26, 2023, 08:45 PM
1 year ago
Affected components
Linear application
Linear GraphQL API
Updates

Resolved

This incident has been resolved.

Wed, Apr 26, 2023, 08:45 PM
2h earlier...

Monitoring

Issue reindexing is 99% complete. Comment reindexing has finished, so searching for comments should now work as expected.

Wed, Apr 26, 2023, 06:11 PM
2h earlier...

Monitoring

The backfill is now 92% complete; most searches should be successful now. We'll update again when the problem has been fully resolved.

Wed, Apr 26, 2023, 03:14 PM
17h earlier...

Monitoring

We've made some changes to enable us to re-index at a faster rate and revised our backfill task to address recently created issues first.

Tue, Apr 25, 2023, 09:47 PM
1h earlier...

Monitoring

Re-indexing is progressing slower than desired. We're evaluating ways to prioritize active issues to be re-indexed first to help better mitigate the impact.

Tue, Apr 25, 2023, 08:33 PM
1d earlier...

Monitoring

We identified an issue that resulted in items being removed from our search index erroneously. Projects and documents have been re-indexed, however we’re still re-indexing all affected issues and comments. During this time searching may not return all possible results.

Mon, Apr 24, 2023, 04:02 PM