Sync & login problems in the app
Resolved
Lasted for 2 weeks

We have rolled out an update to fix the underlying issue that was causing some clients to crash.

Tue, May 17, 2022, 04:24 PM
2 years ago
Affected components

No components marked as affected

Updates

Resolved

We have rolled out an update to fix the underlying issue that was causing some clients to crash.

Tue, May 17, 2022, 04:24 PM
2 weeks earlier...

Monitoring

Update to address issues some of our customers have experienced this week

On Wednesday, we identified a bug that led to crashes and sync issues for customers in some of our larger installations. The original bug caused data to be synced incompletely in those workspaces, which created issues as the app relies on this local cache and sync to provide a fast and realtime user experience. Unfortunately, the fix for this bug caused previously unidentified issues to emerge as more data was persisted to the browser’s local database (IndexedDB). This issue caused Linear to hang or crash for some of our users.

Our engineering team has prioritized this incident above all else over the past two days. We’ve implemented several fixes to address the root cause which was related to persisting multiple large datasets simultaneously. As a result, we are aware of only a handful of issues persisting for a small number of users and are continuing to work on resolving them.

Availability and usability of Linear is our top priority and we want to apologize for any frustration these issues might have caused. If your teammates are still experiencing issues, we recommend restarting the browser and refreshing the Linear client by visiting https://linear.app/refresh. If the issues persist, please reach out to us (hello@linear.app) and we'll help to resolve the situation.

Fri, Apr 29, 2022, 06:00 PM
1d earlier...

Monitoring

We identified further issues persisting data which can lead to browser session crashing. We implemented further fixes to address the situation and are currently monitoring the result. Please contact us (hello@linear.app) if you are still seeing issues.

Thu, Apr 28, 2022, 05:40 PM
2h earlier...

Investigating

We are investigating continued reports of loading issues. If you're facing this, please try restarting Chrome, resetting the app by going to linear.app/refresh, or in the desktop app opening the app menu and selecting Linear > Clear application data.

Thu, Apr 28, 2022, 02:49 PM
21h earlier...

Resolved

We've implemented a fix for this issue, which was related to persisting workspace data into browser storage. We will continue monitoring.

Wed, Apr 27, 2022, 05:44 PM
1d earlier...

Investigating

We are currently investigating this incident affecting some users. If you're facing an issue, please try restarting Chrome or resetting your app (go to linear.app/refresh or opening the command menu with Cmd/Ctrl + K then searching "refresh").

Tue, Apr 26, 2022, 05:07 PM