Windows: Desktop version 1.21.0 not functional
Resolved
Degraded performance
Lasted for 23m

The revised build is available on https://desktop.linear.app/windows for affected users. Windows desktop users on 1.20.0 or previous versions will skip the broken build automatically.

Wed, Sep 20, 2023, 08:36 PM
8 months ago
Affected components
Linear application
Updates

Resolved

The revised build is available on https://desktop.linear.app/windows for affected users. Windows desktop users on 1.20.0 or previous versions will skip the broken build automatically.

Wed, Sep 20, 2023, 08:36 PM
23m earlier...

Investigating

Desktop version 1.21.0 will not open on Windows after installation. We're working to resolve, in the meantime please use Linear on a browser if possible.

Wed, Sep 20, 2023, 08:12 PM