Actions being applied to incorrect issues
Resolved
Degraded performance
Lasted for 1h

Impacts of this incident may have been encountered from 8:53 AM PT to 1:00 PM PT today. This problem was introduced in a fix for an unrelated bug, and we were prompted to investigate by several customer reports. Please let us know at support@linear.app if you notice any similar issues moving forwards.

Tue, Jan 23, 2024, 10:04 PM
3 months ago
Affected components
Linear application
Updates

Resolved

Impacts of this incident may have been encountered from 8:53 AM PT to 1:00 PM PT today. This problem was introduced in a fix for an unrelated bug, and we were prompted to investigate by several customer reports. Please let us know at support@linear.app if you notice any similar issues moving forwards.

Tue, Jan 23, 2024, 10:04 PM
1h earlier...

Monitoring

The fix is deployed, and we can no longer reproduce after refreshing the Linear client. If you're still seeing similar issues, please let us know at support@linear.app.

Tue, Jan 23, 2024, 09:01 PM

Identified

We're deploying a fix that should address the cause of the issue and will update the site again once it lands.

Tue, Jan 23, 2024, 08:57 PM

Investigating

We're continuing to see problems after reverting the change we suspected was responsible. We are continuing to investigate.

Tue, Jan 23, 2024, 08:47 PM
14m earlier...

Identified

We've located the change responsible for this problem and are reverting it now.

Tue, Jan 23, 2024, 08:33 PM

Investigating

We've received several reports of actions (status changes, git branch copy and others) applying to an issue other than the one in focus. We've been able to reproduce a problem in this area and are investigating now.

Tue, Jan 23, 2024, 08:30 PM