Investigating data access issues
Resolved
Full outage

We have successfully restored data for all affected workspaces. We deeply appreciate your patience and understanding throughout this process. A detailed postmortem will be shared next week to provide insights into this incident and our response. This will include learnings and steps we are taking to prevent future occurrences. Workspace admins can refer to Settings > Data recovery to see a summary of data recovered. We thank you for your support and understanding. Any questions, please reach out to us at support@linear.app.

Fri, Jan 26, 2024, 08:58 AM
9 months ago
Affected components
Linear application
Linear GraphQL API
Integrations
Updates

Resolved

We have successfully restored data for all affected workspaces. We deeply appreciate your patience and understanding throughout this process. A detailed postmortem will be shared next week to provide insights into this incident and our response. This will include learnings and steps we are taking to prevent future occurrences. Workspace admins can refer to Settings > Data recovery to see a summary of data recovered. We thank you for your support and understanding. Any questions, please reach out to us at support@linear.app.

Fri, Jan 26, 2024, 08:58 AM
12h earlier...

Monitoring

In the last few hours we’ve restored lost data to 98% of affected workspaces.

In certain instances we were not able to restore a small number of changes (5 or fewer per workspace.) Some changes made to the workspace in the intervening time prevent us from taking certain actions. For instance, we are not able to restore a comment to an issue that has since been manually deleted by a user. If there are errors associated with restoring data in your workspace, they are visible to Admins in Settings > Data recovery.

We are continuing to restore data for remaining workspaces, and will keep sharing updates here when available.

Thu, Jan 25, 2024, 08:41 PM
1d earlier...

Monitoring

If you are one of the impacted users who encountered data loss, you will have received an email from us with detailed information and next steps. If you have not received an email from us, you should not have experienced any data loss. We’ll be focusing on restoring lost data over the upcoming days and will post an update when this work is complete, followed by a detailed post-mortem. Any further questions, please contact support@linear.app.

Wed, Jan 24, 2024, 03:39 PM
2h earlier...

Monitoring

Sync delays are no longer occurring so you should be able to make changes and updates in Linear without any further delays. Any problems, please reach out to us at support@linear.app. We will update when we have further information and include additional details in our post mortem.

Wed, Jan 24, 2024, 01:06 PM

Investigating

We are still investigating problems related to sync delays. Any changes you make are reaching us in a timely manner, however you might experience a delay in seeing these updates or changes in Linear. We're continuing to work on a resolution and will update as more information becomes available.

Wed, Jan 24, 2024, 01:02 PM
56m earlier...

Investigating

We are currently investigating follow-up problems related to sync delays. Rest assured, this will not lead to any data loss. However, you might experience a delay in seeing updates or changes in Linear. We're working to resolve this and will provide more information as it becomes available.

Wed, Jan 24, 2024, 12:05 PM
56m earlier...

Monitoring

Operations are stabilizing, and affected organizations should now be able to make updates in Linear successfully. If you accessed Linear between 04:47 and 09:56 UTC on January 24th, you may have encountered data loss. We are dedicated to restoring this data in the coming days. We’ll post an update when this work is complete, followed by a detailed post-mortem. If you're still having trouble connecting, please contact support@linear.app.

Wed, Jan 24, 2024, 11:08 AM
29m earlier...

Investigating

We've identified the affected organizations and are now prioritizing restoring their services. Following this, we'll focus efforts on restoring any potential data loss during this time frame.

Wed, Jan 24, 2024, 10:39 AM
53m earlier...

Investigating

We’re continuing to investigate increased error rates and inability to access and read data within the application. We have had some data loss, so we’re looking into how many organisations are affected and we will work on restoring data for these organizations.

Wed, Jan 24, 2024, 09:45 AM
22m earlier...

Investigating

We are still investigating increased error rates and inability to access and read data within the application. This may result in missing content in issues and documents or changes not being saved correctly. We'll update with further information as available.

Wed, Jan 24, 2024, 09:23 AM
56m earlier...

Investigating

We're investigating increased error rates and inability to access and read data within the application.

Wed, Jan 24, 2024, 08:26 AM