There should be no further impact from this incident.
These problems were caused by our main database locking up and becoming very slow. We doubled our database size and removed any services that weren't directly related to our clients which helped us recover. Follow-up work continues on our side but impact is resolved.
If you're still experiencing problems in Linear, please let us know at support@linear.app.
Resolved
There should be no further impact from this incident.
These problems were caused by our main database locking up and becoming very slow. We doubled our database size and removed any services that weren't directly related to our clients which helped us recover. Follow-up work continues on our side but impact is resolved.
If you're still experiencing problems in Linear, please let us know at support@linear.app.
Monitoring
We've been investigating database locks causing an adverse effect on all services. We're seeing improvements from our remediation now but are continuing to monitor. Thank you for your patience.
Identified
We're continuing to take further steps to resolve the issue and evaluating the effectiveness of our remediation so far.
Investigating
We're still working on remediation. Users continue to experience difficulty loading Linear and accessing our API.
Investigating
We're continue to work on this problem, but the effects have worsened and some users are not able to load Linear successfully. We'll continue to share updates here as they are available
Investigating
When accessing our API, you may see increased API errors. We are investigating and will provide an update shortly with further information.