Earlier today, some users experienced errors and increased latency when creating and updating Linear issues from Slack. This was caused by internal changes to our notification processing that didn’t scale as expected, leading to processing backlogs in some cases.
The degradation has been resolved, and Slack-based issue actions are now operating normally. We’ve stabilized our infrastructure and are adjusting our approach to prevent similar surges going forward.
Thanks for your patience while we worked through this.
Resolved
Earlier today, some users experienced errors and increased latency when creating and updating Linear issues from Slack. This was caused by internal changes to our notification processing that didn’t scale as expected, leading to processing backlogs in some cases.
The degradation has been resolved, and Slack-based issue actions are now operating normally. We’ve stabilized our infrastructure and are adjusting our approach to prevent similar surges going forward.
Thanks for your patience while we worked through this.
Monitoring
We’ve identified the cause of degraded performance affecting Slack integrations in the US East region. As our systems continue to stabilize, some users may continue to see minor latency when creating or linking issues through Slack.
We’re monitoring closely and will update once the latency resolves fully.
Identified
We’re investigating degraded performance with processing requests with Slack integrations in the US East region.
Creating and linking issues may be delayed.
We’ll keep our status site updated as we investigate and scale up our services.