As we continue processing a surge of background tasks following disruptions involving external services that Linear integrates with, some asynchronous updates in Linear—such as integration activity and the Linear agent in Slack—may experience delays.
Our systems are actively processing queued tasks and we’re monitoring for full recovery.
Monitoring
As we continue processing a surge of background tasks following disruptions involving external services that Linear integrates with, some asynchronous updates in Linear—such as integration activity and the Linear agent in Slack—may experience delays.
Our systems are actively processing queued tasks and we’re monitoring for full recovery.
Monitoring
Earlier today, incidents affecting external services that Linear integrates with resulted in a surge of retried and delayed events being processed by our systems. This temporarily increased system load and created a backlog of background tasks.
While we worked through this backlog, some asynchronous updates in Linear—such as integration activity, the Linear agent in Slack and other background updates—appeared delayed.
Our systems are actively processing queued tasks, and we're seeing stabilization. We'll continue to monitor for full resolution.
Identified
All Linear operations have returned to normal outside of the Linear agent for Slack.
We’ve identified the issue causing failures or delays with the Linear agent and are continuing to monitor for resolution. We’ll share updates as we learn more.
Investigating
We’re seeing improvements in latency for actions taken within Linear or when creating and updating issues through integrations, and are continuing to monitor for any remaining performance degradation.
Separately, we’re investigating reports of the Linear agent in Slack failing to respond to prompts. Our team is working to identify the root cause and will continue to provide updates here as we learn more.
Investigating
We’re investigating degraded performance affecting Linear issue creation and linking, and prompts to the Linear agent in Slack, in the US region.
This impacts Linear issue creation or linking requests coming from integrations (such as Intercom and Zendesk), form templates, and general prompts to the Linear agent for Slack.
Our team is actively investigating the root cause. We’ll continue to provide updates on this status page as we learn more.