We’ve addressed the issue that was causing delays in background task processing earlier today, and task activity has been operating normally again for the past few hours.
A remaining search indexing backlog means some recent changes may still take a few more hours to appear in search results. This does not affect task processing, notifications, webhooks, or other asynchronous updates.
We’re continuing to monitor recovery and will share another update once search indexing has fully caught up.
Monitoring
We’ve addressed the issue that was causing delays in background task processing earlier today, and task activity has been operating normally again for the past few hours.
A remaining search indexing backlog means some recent changes may still take a few more hours to appear in search results. This does not affect task processing, notifications, webhooks, or other asynchronous updates.
We’re continuing to monitor recovery and will share another update once search indexing has fully caught up.
Monitoring
We’ve identified the cause of the delays affecting background activity for some users, including notifications, webhooks, and other asynchronous updates.
We’re actively applying remediation to reduce pressure on our task processing system and restore normal performance.
We’ll share another update as soon as we have more to report.
Monitoring
We're continuing to work through a backlog of delayed background activity affecting some users. This includes delays to email and Slack notifications as well as webhooks.
We've scaled up our infrastructure to process the backlog more quickly and are actively monitoring progress.
Notifications affected by this backlog should come through in the coming hours and we'll share another update once the backlog has cleared.
Monitoring
We've monitoring further delays in background activity that have affected some users in recent days.
While most of the service is operating normally, some notifications and updates may still be delayed as recovery continues for affected users.
We’re seeing improvement and will share another update soon.
Resolved
We mitigated the issue causing delays in background event processing, and the backlog has returned to regular levels.
Systems are operating normally — you should no longer experience issues with notification or email delivery, webhooks, or other event-driven updates.
Please reach out to support@linear.app if you continue to experience any related problems.
Monitoring
We identified failures with our event processing and our backlog of events has returned to regular levels and delays are no longer significant.
We're continuing to monitor for stability.
Investigating
We’re investigating delays in background processing. This may affect things like notifications, emails, webhooks, automations, and some integrations.
We’re working to identify the cause and mitigate the issue, though are seeing early signs of stabilization.